wp-bugSom många säkert upptäckt så har det pratats mycket om WordPress och säkerhet på senaste tiden. Dels så har vi haft inte mindre än 3st säkerhetsreleaser för WordPress 2.8.

Nu i början av september så har man även upptäckt att det gått en våg av attacker mot äldre versioner av WordPress. Denna attack går ut på att manipulera din permalänksstruktur och skapa en bakdörr för intrång i din installation. Den första indikationen på att du har blivit attackerad om du använder en äldre version av WordPress är att dina permalänkar inte fungerar som de ska och innehåller märkliga tecken, dessa tar sig formen enligt följande

exempel.se/kategori/post-titel/%&(%7B$%7Beval(base64_decode($_SERVER%5BHTTP_REFERER%5D))%7D%7D|.+)&%/

Att uppmärksamma om du misstänker att något är galet är här speciellt ”eval” och ”base64_decode”. Hittar du också  användare med administrativa rättigheter som du inte känner igen så är detta ytterligare en indikation på att du blivit attackerad.

Mer att läsa om dessa attacker och säkerhet i WordPress:

Nu ska man inte bli osäker på WordPress av denna anledning. Håller man WordPress, dess tillägg och teman uppdaterade med de senaste versionerna så har man inget att vara nervös över. En sådan sak som att man släppt 3st säkerhetsuppdateringar nyligen visar på att man så snart ett säkerhetshål uppdagas täpper igen dessa.

Lösningen för att motverka intrång är helt enkelt att uppgradera WordPress (och att alltid göra det när nya versioner finns tillgängliga). Har du inte redan uppgraderat, gör det nu!

Jag som skriver här heter Mattias Tengblad. En kaffedrickande webbutvecklare med förkärlek till WordPress, är filmälskare, djurvän och tekniknörd. Detta inlägg postades den . Du kan följa uppdateringar till inlägget via RSS-flödet.